Raven Help Forum  

Go Back   Raven Help Forum > Raven Pro > Raven - Help and Discussion
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-25-2017, 10:49 PM
AHopson AHopson is offline
Junior Member
 
Join Date: Nov 2013
Posts: 8
Default Batch Correlation Issues

Hello,
I am having trouble with the bacth correlator function. When I start the correlation it runs very slow and for EVERY file I receive a message that says "Raven Pro is unable to read and decode the entire file". I get the same message when I open them individually, even though the whole file does open. However, When I page the sound in 1 min increments it opens fine. Each file is in wav format and 5 minutes long. I am thinking the problem is the length of the file and wanted to know if there is a setting in the batch correlation (or another part of Raven) that would allow me to reduce the length of the recording in large batches? Or run the batch correlator in a more time effective manor?

Thank you,
Adrienne
Reply With Quote
  #2  
Old 03-27-2017, 12:07 PM
Michael Pitzrick Michael Pitzrick is offline
Administrator
 
Join Date: Sep 2008
Posts: 233
Default Re: Batch Correlation Issues

Quote:
Originally Posted by AHopson View Post
Hello,
I am having trouble with the bacth correlator function. When I start the correlation it runs very slow and for EVERY file I receive a message that says "Raven Pro is unable to read and decode the entire file". I get the same message when I open them individually, even though the whole file does open. However, When I page the sound in 1 min increments it opens fine. Each file is in wav format and 5 minutes long. I am thinking the problem is the length of the file and wanted to know if there is a setting in the batch correlation (or another part of Raven) that would allow me to reduce the length of the recording in large batches? Or run the batch correlator in a more time effective manor?

Thank you,
Adrienne
Hi Adrienne,

I'm not familiar with this set of symptoms, but can comment that you are asking Raven to do some pretty hefty lifting there, correlating a batch of 5-minute spectrograms! I have a hunch that Raven is struggling with the memory allocated to it. One way to reduce demand on memory would be to decrease overlap to 0%, which will decrease the size of each spectrogram matrix that must be stored in memory and correlated.

You can also increase Raven's memory allocation by using Raven Memory Manager (in the "Window" menu) to increase Maximum Raven Memory Usage to "High". You may want to close other software applications on computer while you are using this setting, to avoid putting your operating system into an unstable state.

You can increase the amount of memory available to Raven at each setting ("Low", "Medium" and "High") by installing more system memory. I've had Raven use up to 18 GB of memory, and might have gotten even more if I'd had more system memory installed!

When you're done doing batch spectrogram correlations, you may want to set Memory Manager back to "Medium" to avoid system memory issues in the future when you are using Raven with other software applications open.

-Mike
Reply With Quote
  #3  
Old 03-27-2017, 02:18 PM
Michael Pitzrick Michael Pitzrick is offline
Administrator
 
Join Date: Sep 2008
Posts: 233
Default Re: Batch Correlation Issues

Quote:
Originally Posted by AHopson View Post
Hello,
I am having trouble with the bacth correlator function. When I start the correlation it runs very slow and for EVERY file I receive a message that says "Raven Pro is unable to read and decode the entire file". I get the same message when I open them individually, even though the whole file does open. However, When I page the sound in 1 min increments it opens fine. Each file is in wav format and 5 minutes long. I am thinking the problem is the length of the file and wanted to know if there is a setting in the batch correlation (or another part of Raven) that would allow me to reduce the length of the recording in large batches? Or run the batch correlator in a more time effective manor?

Thank you,
Adrienne
Hi Adrienne,

If you are still having trouble after increasing Raven's memory allocation, please initiate a Raven support issue by emailing raven_support@cornell.edu. Include a problem report (again), what operating your computer has, how much system memory your computer has installed in it, and what version of Raven you are using. You can find the latter by selecting "About Raven Pro" from the Help menu, and reporting the top two lines on the right side.

Thank you.

-Mike
Reply With Quote
  #4  
Old 03-28-2017, 11:45 AM
Michael Pitzrick Michael Pitzrick is offline
Administrator
 
Join Date: Sep 2008
Posts: 233
Default Re: Batch Correlation Issues

Quote:
Originally Posted by AHopson View Post
Hello,
I am having trouble with the bacth correlator function. When I start the correlation it runs very slow and for EVERY file I receive a message that says "Raven Pro is unable to read and decode the entire file". I get the same message when I open them individually, even though the whole file does open. However, When I page the sound in 1 min increments it opens fine. Each file is in wav format and 5 minutes long. I am thinking the problem is the length of the file and wanted to know if there is a setting in the batch correlation (or another part of Raven) that would allow me to reduce the length of the recording in large batches? Or run the batch correlator in a more time effective manor?

Thank you,
Adrienne
Adrienne,

We've found a bug in Raven that prevents it from loading at least one audio format that commonly has the ".wav" file extension. If you are using WAV files, would you be willing to re-submit this issue as a support request by emailing raven_support@cornell.edu? Attaching a problem WAV file that isn't too big to your email would be very helpful.

Thank you.

-Mike
Reply With Quote
  #5  
Old 04-26-2017, 02:24 PM
HIstormpetrel HIstormpetrel is offline
Junior Member
 
Join Date: Apr 2017
Posts: 1
Default Re: Batch Correlation Issues

I am also having trouble with Batch Band Filter--"Raven Pro is unable to read and decode entire file" pops up for each file. Each wav file I am using is 1 hour long, and I have 4 files that I am applying the batch band filter to at a time.
Reply With Quote
  #6  
Old 04-27-2017, 09:29 AM
Michael Pitzrick Michael Pitzrick is offline
Administrator
 
Join Date: Sep 2008
Posts: 233
Default Re: Batch Correlation Issues

Quote:
Originally Posted by HIstormpetrel View Post
I am also having trouble with Batch Band Filter--"Raven Pro is unable to read and decode entire file" pops up for each file. Each wav file I am using is 1 hour long, and I have 4 files that I am applying the batch band filter to at a time.
Hi Nicole,

Rather than attempting to troubleshoot what is happening in the context of this forum, may I request that you email me at Raven Tech Support <raven_support@cornell.edu>? Please include details, such as:
  • What operating system you have
  • What version of Raven you have (Help > About Raven Pro, report top two lines)
  • What you are doing at the time of the warning or error message
  • The exact wording of each warning or error message Raven presents
  • Details about the sound files involved (audio format, sample rate, bit depth, length)
  • Whether this problem also occurs when you are opening the same sound files in Raven
If possible, make available through email attachment or download link an example of a sound file that triggers the warning message.

Thank you.

-Mike
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:41 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.